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Terms of use  

Terms of Use Applicable to the User Documentation 

The legal notices, disclaimers, terms of use, and other information contained herein (the 
"terms") apply only to the information discussed in this documentation (the 
"Documentation") and your use of it. These terms do not apply to or govern the use of 
websites controlled by Security & Communications, Inc. or its subsidiaries (collectively, 
"Security & Communications")or any Security & Communications-provided products. 
Security & Communications products are available for purchase and subject to a 
separate license agreement and/or terms of use containing very different terms and 
conditions. 

Terms of Use and Copyright and Trademark Notices 

The copyright in the Documentation is owned by Security & Communications and is 
protected by copyright and other intellectual property laws of the United States and other 
countries. You may use, print out, save on a retrieval system, and otherwise copy and 
distribute the Documentation solely for non-commercial use, provided that you (i) do not 
modify the Documentation in any way and (ii) always include Security & 
Communications's copyright, trademark, and other proprietary notices, as well as a link 
to, or print out of, the full contents of this page and its terms. 

No part of the Documentation may be used in a compilation or otherwise incorporated 
into another work or with or into any other documentation or user manuals, or be used to 
create derivative works, without the express prior written permission of Security & 
Communications. Security & Communications reserves the right to change the terms at 
any time, and your continued use of the Documentation shall be deemed an acceptance 
of those terms. 

Other company, product and service names may be trademarks or service marks of 
others. 

É 2006 - 2013 Security & Communications, Inc. All rights reserved. 
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Disclaimer  

 
THE DOCUMENTATION AND ANY INFORMATION AVAILABLE FROM IT MAY INCLUDE 
INACCURACIES OR TYPOGRAPHICAL ERRORS. Security&Communications Software 
MAY CHANGE THE DOCUMENTATION FROM TIME TO TIME. 
Security&Communications Software MAKES NO REPRESENTATIONS OR WARRANTIES 
ABOUT THE ACCURACY OR SUITABILITY OF ANY Security&Communications Software-
CONTROLLED WEBSITE, THE DOCUMENTATION AND/OR ANY PRODUCT 
INFORMATION. 
Security&Communications Software-CONTROLLED WEBSITES, THE DOCUMENTATION 
AND ALL PRODUCT INFORMATION ARE PROVIDED "AS IS" AND 
Security&Communications Software DISCLAIMS ANY AND ALL EXPRESS AND IMPLIED 
WARRANTIES, INCLUDING BUT NOT LIMITED TO WARRANTIES OF TITLE AND THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A 
PARTICULAR PURPOSE. IN NO EVENT SHALL Security&Communications Software BE 
LIABLE TO YOU FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, 
PUNITIVE, OR CONSEQUENTIAL DAMAGES (INCLUDING BUT NOT LIMITED TO 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES, LOSS OF DATA, LOSS OF 
PROFITS, AND/OR BUSINESS INTERRUPTIONS), ARISING OUT OF OR IN 
ANY WAY RELATED TO Security&Communications Software -CONTROLLED WEBSITES 
OR THE DOCUMENTATION, NO MATTER HOW CAUSED AND/OR WHETHER BASED 
ON CONTRACT, STRICT LIABILITY, NEGLIGENCE OR OTHER TORTUOUS 
ACTIVITY, OR ANY OTHER THEORY OF LIABILITY, EVEN IF Security&Communications 
Software IS ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME 
STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION 
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE 
LIMITATIONS MAY NOT APPLY TO YOU. 

 
    
    

 

CopyrightÉ 2006-2013 Security&Communications Software, Inc. 
All rights reserved. 
Security&Communications Software, Inc.È  
 

Security & Communications Software, 
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 - are registered trademarks of 
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 - are registered trademarks of Microsoft 
Corporation  

   

Some parts of this guide use public information from RSA Data Security, Inc. and Microsoft 
Corporation. 
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Preparing for an installation  

Technical requirements  

To work with pkiStorage you need to have IBMâPC compatible computer with the 
following characteristics: 

Table 1. Minimum requirements for pkiStorage 

Name Value 

CPU Pentium II 1 GHz 

RAM 128 

HDD 10 

VIDEO 800ɛ600 SVGA 

DVD ROM - 

Table 2. Recommended settings for pkiStorage 

Name Value 

CPU Intel Core i3 2 GHz 

RAM 20481 

HDD 10 

VIDEO 1280ɛ1024 SVGA 

DVD ROM - 

Operating systems  

pkiStorage supports the following operating systems: 

¶ Windows XP SP2 x86, x64, 

¶ Windows 2003 Server SP2 x86, x64, 

¶ Windows 2003 Server R2 x86, x64, 

¶ Windows 2008 Server SP1 x86, x64, 

¶ Windows 2008 Server R2 x86, x64, 

¶ Windows Vista SP1 x86, x64, 

¶ Windows 7 x86, x64, 

¶ Windows 8 x86, x64, 

¶ Windows 8.1 x86, x64, 

¶ Windows 2012 Server x86, x64. 

                                                   

1 For Windows Vista, 7, 8, 2012 it is need at least 1 GB of RAM.  
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Software environment  

In order to successfully run pkiStorage you will need to have the following software 
environment installed on your PC: 

¶ Microsoft .NET Framework v3.5 or higher 
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Installing   pkiStorage  

Running  the  installation  

Installation of pkiStorage is performed by running an installation package 

pkistgAAAdd_cc.EXE 

where 

aaa ï current version number of pkiStorage, 

dd ï language of the user interface, 

cc ï platform of Windows 

?Note 

For example, package: pkistg101en_x86.exe means installation of pkiStorage version 1.0.1 
for x86 platform with English user interface 

Installation process  

Start page  

After executing the installation package you will see the following page: 

 

Further in installation process you will need to do the following: 
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License Agreement  

1. Read and accept license agreement: 

 

 

Installation Folder  

2. Specify the folder where pkiStorage will be installed. 
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Installation readiness  

3. Now all parameters have been specified and installation will begin: 

 

 

Copying  files  

After pressing ñInstallò the actual copying of files will start: system will create registry 
entries and add a pkiStorage program group. 
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Completion of the installation  

After completing the installation you will see the following screen: 

1 
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Removing  pkiStorage   

To remove pkiStorage from your PC you need to use:  

Control Panel > Unistall Programs (for Windows 7): 

 

Press Uninstall for removing pkiStorage from your computer. 
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Setting up  pkiStorage   

Configuring pkiStorage   

To set up parameters do the following: 

1. Select Start->All programs->pkiStorage->pkiStorage GUI 

2. In the program select Tools->Options 

3. You will see configuration options for pkiStorage : 

 

Options tabs contain the following parameter areas: 

¶ Security  ï all parameters regarding for security, 

¶ System  ï all parameters regarding for Windows 

¶ USB ï all parameters regarding USB support, 

¶ Check ï all parameters regarding periodical check of application state, 

¶ Backup ï all parameters regarding save backup copy of storage. 

Below you can find detailed description of the parameters. 

Security  parameters  

Intro  

Security parameters are listed under section Security Settings and below you can find a 
description: 

Encryption  

Create key from 

This parameter sets key source type for encryption and decryption of a storage.  
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This version of pkiStorage support the following formats: 

¶ Password 

Encryption method 

This parameter sets the cryptography algorithm using for encryption and decryption 
of a storage.  

This version of pkiStorage support the following algorithms: 

¶ AES with 256-bit 

Protect  

Clear key from memory after loading 

This parameter sets the usage of the encryption key in the memory after storage 
loading. Enable this mode for more security of your encryption keys. 

Ask password, when main window will be opened 

Main window of application can be hidden or restored on Windows screen. For more 
security you can enable this mode and before restoring the window the application will 
ask a storage password. 

Close password viewing after 

Viewing window of password record can be closed once this timeout expires. 

Hide after inactivity timeout 

Main window of application can be hidden automatically once this timeout of a user 
inactivity expires. 

System  parameters  

Intro  

System parameters are listed under section System Settings and below you can find a 
description: 
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System  

Start with Windows 

This parameter sets automatical starting of the application after loading Windows.  

View in taskbar 

This parameter sets the display of the application icon in Windows taskbar list. 
Usually, you can find application icon in the tray menu.  

Last storages  

After start application 

This parameter sets storage loading mode after application start.  

This version of pkiStorage support the following storage loading modes: 

¶ None 

¶ Load last opened storage 

¶ Load last saved storage 

Updates  

Check for updates after start 

This parameter sets checking for a new version after the application start.  

USB  parameters  

Intro  

USB parameters are listed under section USB Settings and below you can find a 
description: 

 

USB devices  

After attaching device 

This parameter sets necessary actions after attaching USB device with storages.  
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This version of pkiStorage support the following actions: 

¶ None 

¶ Load first founded  storage 

¶ Load last changed storage 

¶ View storages list. 

At last actions a list of founded storages will be viewed and you can select necessary 
storage.  

Searching storage in 

This parameter sets searching storages mode after attaching USB.  

This version of pkiStorage support the following USB searching modes: 

¶ Root folder 

¶ All folders 

¶ Selected folder 

At last mode after clicking the button ñéò you will see ñopen folderò dialog and you can 
select the necessary folder with storages.  

Check  parameters  

Intro  

Check parameters are listed under section Check Settings and below you can find a 
description: 

 

Checking state  

Check application state every 

This parameter sets checking application state timeout.  

This version of pkiStorage support the following checking actions: 

¶ Saving backup copy of opened storage (if enable).  
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Backup  parameters  

Intro  

Backup parameters are listed under the section Backup Settings and below you can find 
a description: 

 

Create backup  

in 

This parameter sets where will be saved backup copy of opened storage.  

This version of pkiStorage support the following backup locations: 

¶ None.  

¶ Temporary files, 

¶ Selected folder. 

At Temporary files mode backup copies of storage located in user profile folder: 

<User>\AppData\Roaming\SE&COM Software Inc\pkiStorage free 
Edition\1.0.0.0\\backup 

 folder. 

Selected folder 

This parameter sets the folder where backup copy of opened storage in Selected 
folder mode will be saved.  
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Certificates and passwords storage  

Overview  

pkiStorage GUI has the following features for a storage: 

Security: 

V Creating encryption or decryption keys from password, 

V Encryption of a storage with long size storage password , 

V Decryption of a storage with same as encryption storage password, 

Automatic services: 

V Start application after loading Windows, 

V Opening last opened or last saved storage after start application, 

V Opening storage after USB drive attached and closing after detached. 

?Note 

This version of pkiStorage supported USB Flash drive only. 

V Closing application window after user inactivity timeout, 

V Closing password view window after timeout, 

Digital X.509 certificates: 

V Import personal (with secret keys) digital certificates from PKCS#12 (PFX) files, 

V Import other people (without secret keys) digital certificates from  CER files, 

V Import personal (with secret keys) digital certificates from Windows certificates store 
(current user or local machine), 

V Import other people (without secret keys) digital certificates from Windows 
certificates store  (current user or local machine), 

V Export personal certificate export, 

V Sending personal certificate to your friends by email, 

V Manual or automatically registration of personal and other people certificates in 
Windows certificates store after opening the storage, 

V Manual or automatically deregistration of personal and other people certificates from 
Windows certificates store after closing the storage, 

V View certificate, 

V Sort certificates by: 

o Personal or Other people 

o Key usage type 

o Ownerôs name 

o Issuer name 

o Issued date 

o Expired date 

o Group 

o Registration 

V Checking trust status of certificates 

Password records: 

V Storing password records with next fields: 
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o Resource (URL) 

o Identifier 

o Password 

o Control phrase 

o Control question 

o Control answer 

o Comment 

o Group 

o Create date and time 

V Add new password records, 

V Edit password record, 

V View password record, 

V Sort password records by: 

o Resource (URL) 

o Create date 

o Group 

V Searching password record by  fields: 

o part of  Resource (URL) 

o Create date from 

o Create date to 

Main window  

After starting pkiStorage GUI you  can to view main application window: 
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?Note 

After starting,  if application do not Open a storage, main window will be minimized after 30 
seconds. To restore main window in normal mode double click pkiStorage icon in tray panel 
of Windows. 

To manage the view of the main window you can use double mouse click on pkiStorage 
icon in tray panel: 

 

Some operations with storages described below you can use by click right mouse button 
on this icon: 

 

To manage the contents of the main window you can use the following main menu items: 

 File->New->PKIStorage 

Create a new file for saving storage. 

File->Open 

Open an existing storage. 

File->Close 

Close opened storage. 

File->Save 

Save opened storage content  in a file. 

File->Save As 

Save storage content in an another or new file. 

File->Exit 

Exit the application. 

Tools->Options 

Set the parameters of application. 

Certificates->Add from->File 

Add personal or other people certificates from PFX or CER files. 

Certificates->Add from->User store 

Add personal or other people certificates from a current user Windows 
certificates store. 
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Certificates->Add from->Machine store 

Add personal or other people certificates from a local machine Windows 
certificates store. 

Certificates->Remove 

Remove personal or other people certificates from a storage. 

Certificates->Copy 

Copy a personal certificate from a storage to the clipboard in BASE64 format. 

Certificates->Properties 

View personal or other people certificate properties. 

Certificates->Send 

Send a personal certificate without a private key to friends by email . 

Certificates->Check status 

Check trusted status personal or other people certificates. 

Certificates->Registration 

Registration (copying) personal or other people certificates to the current user 
Windows certificates store. 

Certificates->Deregistration 

Deregistration (removing) personal or other people certificates from the current 
user  Windows certificates store. 

Certificates->Get new My certificates 

Buy a new personal certificate on buypki.com. 

Passwords->Add 

Add new password record to storage. 

Passwords->Remove 

Remove password records from storage. 

Passwords->Edit 

Edit existing password record in storage. 

Password->Properties 

View password record properties. 

Help->View Help  

View user guide in pdf format. 

Help->View Quick Help  

View quick start guide in pdf format. 

Help->Feedback 

Send feedback message to secomsoft.com. 

Help->Check for updates 

Check for existing new versions on secomsoft.com. 

Help->About pkiStorage 

View information about current version of application. 

Operational tabs 

On this tabs you will find certificates and password record lists, menus and other: 
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Certificates 

Digital certificates X.509  in a storage: 

 

Passwords 

Password records in a storage: 

 




















































